Jenkinsx-3 waiting for lighthouse trigger in config - build is not moving on

I installed JenkinsX-3 on my Openshift CRC Cluster. It works so far. But I get stuck with following message, after the repo has been created. Can anybody help me to continue with this issue?

waiting up to 20m0s for a trigger to be added to the lighthouse configuration in ConfigMap config in namespace jx for repository: myorganization/antother-test

So how do I add the trigger into the config map. I oppened the configmap in Openshift, but what do I need to add where in the YAML?

We are evaluating JenkinsX for our Enterprise Environment at SBB (Biggest Swiss Railway Company). Is there anybody who could consult us?

Hi there - there’s some docs here that help describe about adding custom triggers for your own application repos but I wonder from you message if you are saying the initial install does not complete and hangs on that line?

waiting up to 20m0s for a trigger to be added to the lighthouse configuration in ConfigMap config in namespace jx for repository: myorganization/antother-test

What command are you running or the last couple of steps to recreate the problem and to know where you are in the process?

FWIW for a bit more interactive help you could also ask in the slack channels as they are pretty active https://jenkins-x.io/community/#slack

Thanks.

Hi, thank you for your help. It is exactely what I need. The setup of lighthouse triggers. I will try what is written in the docu and give feedback. I couldn’t find this docu in the step by step tutorial to generate a quickstart or spirngboot application.

OK great and thanks for sharing where you are in the process, we’ll get a link added to the quickstarts.

This is what I executed, should this not automatically go through?

[manuel:~/devsbb … enkinsx/jenkinsx3] $ jx create project spring
? git owner: mygitorga
X Sorry, your reply was invalid: Repository name is required
? git repository name: antother-test
Creating repository mygitorga/antother-test
? Language: java
? Group: ch.sbb
? Dependencies: actuator
Created Spring Boot project at /Users/manuel/devsbb/workspaces/jenkinsx/jenkinsx3/antother-test
The directory /Users/manuel/devsbb/workspaces/jenkinsx/jenkinsx3/antother-test is not yet using git
? Would you like to initialise git now? Yes

? Commit message: chore: initial import

Git repository created
? Confirm the catalog folder you wish to use on this project [Use arrows to mov? Confirm the catalog folder you wish to use on this project maven-java11
selected catalog folder: maven-java11
created /Users/manuel/devsbb/workspaces/jenkinsx/jenkinsx3/antother-test/.lighthouse/jenkins-x/Kptfile
replacing placeholders in directory /Users/manuel/devsbb/workspaces/jenkinsx/jenkinsx3/antother-test
app name: antother-test, git server: github.com, org: mygitorga, Docker registry org: mygitorga
skipping directory “/Users/manuel/devsbb/workspaces/jenkinsx/jenkinsx3/antother-test/.git”
skipping ignored file “/Users/manuel/devsbb/workspaces/jenkinsx/jenkinsx3/antother-test/HELP.md”
Pushed Git repository to https://github.com/mygitorga/antother-test
cloned https://github.com/mygitorga/jx3-cluster-repo.git to /var/folders/6t/vc9qjw1x1yg1kvb_8k04m6cc0000gn/T/jx-git-650731855
modified file /var/folders/6t/vc9qjw1x1yg1kvb_8k04m6cc0000gn/T/jx-git-650731855/.jx/gitops/source-config.yaml
checking if the new repository is an Environment: https://github.com/mygitorga/antother-test.git
Created Pull Request: https://github.com/mygitorga/jx3-cluster-repo/pull/4
Waiting up to 20m0s for the pull request https://github.com/mygitorga/jx3-cluster-repo/pull/4 to merge…
Pull Request https://github.com/mygitorga/jx3-cluster-repo/pull/4 is merged at sha e69a8045c52398d2dc619482f7b2cbe9115816ee after waiting 7m46.972459052s
created pull request https://github.com/mygitorga/jx3-cluster-repo/pull/4 on the development git repository https://github.com/mygitorga/jx3-cluster-repo.git
waiting up to 20m0s for a trigger to be added to the lighthouse configuration in ConfigMap config in namespace jx for repository: mygitorga/antother-test
error: failed to wait for repository to be setup in lighthouse: failed to find trigger in the lighthouse configuration in ConfigMap config in namespace jx for repository: mygitorga/antother-test within 20m0s
error: failed to wait for the pipeline to be setup mygitorga/antother-test: failed to run ‘jx pipeline wait --owner mygitorga --repo antother-test’ command in directory ‘’, output: ‘’

It would be great to have an example in the documentation of the correct part of the Configmap content which needs to be adjusted.

incidentally I’ve improved jx project to add more information about what’s going on via the Pull Request message. Also once the PR merges it outputs that you can see the effect of the PR merging via jx admin log

BTW did the Pull Request automatically merge? If so it sounds like there was an issue in the boot job applying the new changes - the error will be in jx admin log

Hi

No the pr with adding the repo didn’t merge automatically. I merged it in Github by hand. But after it wants me to edit the Lighthouse ConfigMap. The configMap I have. But I don’t know what to edit there.
I also created an issue:

Will JenkinsX 3 work as well with Bitbucket?

We are evaluating Jenkins X as a Gitops tool for a relatively big Openshift environment. Would you or somebody else have time to do a short remotesession with me (Paid of course)? It would safe me time and bring me faster forward.

I checked with jx admin log, no errors. I reinstalled the git operator. I updated the local jx3 instance and plugins. I use now version: 3.0.692.

After I reainstalled the git operator the lighthouse config Map seems to be updated with all existing repos. But if I create a new Repo it gets stuck at the same step.
waiting up to 20m0s for a trigger to be added to the lighthouse configuration in ConfigMap config in namespace jx for repository: me/sixth-quickstart

Ok, I got a step further, but something doesn’t seem run fluent. If I push after the first cluster Repo Job did run again, another clusterjob runs and updates the Lighthouseconfig in the Cluster. Then the Project setup continues. The start of the pipeline is hanging at the state pending / initializing. I need to analyze that. But defenitely something doesn’t run yet how it should accoording to the push events and ConfigMap updates.

Hi, I’m also encounter same issue for new quickstart. Below is error trace from jx import. Also, I’ve updated jx plugins and cli (version: 3.0.752)

#jx import -u <github_project_url>

WARNING: It looks like the boot job failed to setup this project.
You can view the log via: jx admin log
error: failed to wait for repository to be setup in lighthouse: failed to find trigger in the lighthouse configuration in ConfigMap config in namespace jx for repository: <repository_name> within 20m0s
# jx admin log
kubectl apply --force --prune -l=gitops.jenkins-x.io/pipeline=namespaces                -R -f config-root/namespaces
error: read tcp 192.168.68.100:57658->54.151.158.190:443: read: connection reset by peer